Author Topic: Snow Leopard 10.6  (Read 3239 times)

Melinda DePalma

  • Member
  • *
  • Posts: 179
    • Productive Computing
Snow Leopard 10.6
« on: September 04, 2009, 09:40:21 AM »
The Change Printer Plug-in current version 3.0.2.3 is compatible with Snow Leopard.

As with any new release of an operating system, there may be additional unexpected issues that may not have been uncovered during our testing efforts. If you encounter any issues, please report them directly to support@productivecomputing.com