Plug-ins > Address Book Manipulator

Snow Leopard 10.6

(1/1)

Melinda DePalma:
The Address Book Manipulator current version 2.0.3.4 is compatible with Snow Leopard.

As with any new release of an operating system, there may be additional unexpected issues that may not have been uncovered during our testing efforts. If you encounter any issues, please report them directly to support@productivecomputing.com

Navigation

[0] Message Index

Go to full version