Productive Computing, Inc. Support Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

SMF - Just Installed!

Pages: [1]   Go Down

Author Topic: query help  (Read 256 times)

tcpms

  • Member
  • *
  • Posts: 25
query help
« on: May 02, 2017, 05:21:41 PM »

When I create a customer query using the 'FullyQualifiedName' field, this is what happens:

'John Doe' or 'Steve Smith' work just fine.

'John & Jane Doe' or 'Steve & Susie Smith' fail.

Is the '&' treated as a special character when executing the query? If so, how do I encode it so that it does not fail?
Logged

Geoffrey Gerhard

  • Guru
  • Member
  • ****
  • Posts: 470
Re: query help
« Reply #1 on: May 03, 2017, 08:28:43 AM »

The encoded version of & is &

I'm not sure how/whether that encoding is/should be handled by the PCQO plug-in. In the desktop version there's a function that will format the values to the TYPE QB expects, and it may do that formatting automatically when you're applying the equivalent AddFieldWithValue function. I don't see anything in the PCQO docs that address the question.

If the function doesn't do it natively, you may need to add your own Substitute for [ "&" ; "&" ] and any other reserved characters you might encounter. Note that if you're writing any returned values to an FMP record, you'll need to reverse the Substitute parameters.

HTH!

Geoffrey Gerhard
Creative Solutions Incorporated
14000 Creekside Drive
Matthews, NC  28105
704) 814-6852
Logged
Pages: [1]   Go Up