Plug-ins > FM Books Connector

Quickbooks already has a company file open

(1/1)

zaphod:
We have been using fmbooks connector for months without any problems.

Now when trying to connect to our Canada QB file, I am getting the message:

"Quickbooks already has a company file open.  If you want to open another company file, close this one first".

Then FileMaker crashes.


The workflow we use is to open the QB file, then I run PCQB_BeginSession( ""; "" ) to open a session to the file that is currently open.

It seems like the plugin can't figure out that the file is already open for some reason.

I tried uninstalling QB Canada and reinstalling, and re-authorizing the plugin in the QB application, but that only worked once and then it started complaining about not being able to open 2 files at once.

Any help is really appreciated.  Haven't been able to sync for 11 days now, and accounting is getting really behind.

Edit:  I've also tried the "Test" button in the Demo file, but even though it returns 0, which should be successful, it still displays the message.
screenshot: http://imgur.com/a/TFDLD

Francis Sarmiento:
Please close QuickBooks ad open the Task Manager to make sure that there are no instances of "QBW32.exe" active in the processes list. If there are, go ahead and clear all instances of QB and try opening QuickBooks again and try running the test again.

zaphod:
I did a full uninstall and reinstall of quickbooks pro canada 2016, and things are working again.

Really unsure what was causing the problem.  I'll update my post if the problem comes back.

Navigation

[0] Message Index

Go to full version