Plug-ins > PDF Manipulator Announcements & Version Updates

PDF Manipulator - OSX 10.9 Mavericks Compatible

(1/1)

Sarah Ly:
PDF Manipulator version 3.0.0.1 for Mac is compatible w/ OSX 10.9 Mavericks!

Please visit http://www.pdfmanipulator.com for more information.

Navigation

[0] Message Index

Go to full version