Author Topic: PlugIn not writing check even though QB ID is retrieved  (Read 1476 times)

REMAX

  • Member
  • *
  • Posts: 1
PlugIn not writing check even though QB ID is retrieved
« on: April 09, 2012, 03:27:13 PM »
Hello,  I am on QuickBooks 2011, Windows XP, FileMaker 9 Advanced in Demo mode.  Actual user will be on Windows 7 with purchased plug-in with FileMaker 9.  I have just upgraded from FileBooks Link to FMBooks Connector.  I have updated all of my scripts and have just started testing and the following is happening: I am writing a check (or several checks) from FileMaker to QuickBooks.  The script loops through and writes the appropriate checks, as needed.  In this case I am writing 3 different checks.  For each one I begin a session, write the check, capture the QuickBooks ID and then end the session.  Then I move on to the next.  I get no errors but no checks are actually written in my check register.  I actually capture the QuickBooks ID for each check; however, I noticed that the QBID is the same for all three, which it shouldn't be.  Any thoughts about what is wrong and why I wouldn't get any errors?

Geoffrey Gerhard

  • Guru
  • Member
  • ****
  • Posts: 470
Re: PlugIn not writing check even though QB ID is retrieved
« Reply #1 on: April 09, 2012, 05:24:08 PM »
You mention updating your scripts from FMBooks Connector. Are you still creating qbXML blocks and using the PCQB_Z... functions to pass a Request and Parse a Response? I've encountered situations in which the plug-in does not recognize that the xml is malformed and fails to return an error. If so, post the xml Request text here and maybe the problem will be obvious. Or try testing the block using the PCQB_ZValidateXML function.

I've seen a failure similar to what you've reported when QB has crashed or frozen, but I'm assuming that's not the case here. Which version of the plug-in are you using?

HTH!


Geoffrey Gerhard
Creative Solutions Incorporated
14000 Creekside Drive
Matthews, NC  28105
704) 814-6852